CSF Error: Unable to connect to https://download.configserver.com

This tutorial has been written to help resolve a CSF dependency issue in regards to running upgrades when receiving the following errors from CSF, ConfigServer Firewall:

Unable to connect to https://download.configserver.com, retry in xxx seconds. An Upgrade button will appear here if new version is detected. - Error is typically seen in the GUI from the control panel

Oops: Unable to download: Protocol scheme 'https' is not supported (Crypt::SSLeay or IO::Socket::SSL not installed) - Error is typically seen in the CLI when you attempt to run csf -u

These errors are seen because the packages perl-Crypt-SSLeay and perl-Net-SSLeay are missing. To install these missing packages, simply run the following from SSH as root:

yum install perl-Crypt-SSLeay perl-Net-SSLeay

 
Follow the on screen prompts to install these missing dependencies. Once installed, CSF will be able to upgrade itself once again either through the control panel GUI or from the CLI command prompt.

  • Email, SSL
  • 87 Users Found This Useful
Was this answer helpful?

Related Articles

Setup Your Own Private VPN with PPTP

PPTP VPN IntroductionTired of being geo blocked and not being able to watch your favorite TV...

Protect DirectAdmin from Brute Force Attacks

A common method of gaining access over a server is to use a technique called a brute force...

Changing Your Server's Time Zone

Changing the time zone that your server is set to is relatively simple and straight forward. In...

Synchronizing Your Server's Clock

Synchronizing your server's clock is not very difficult as there is a program that can be ran by...

CSF Error: *WARNING* URLGET set to use LWP but perl module is not installed, reverting to HTTP::Tiny

A common error clients come across after initially installing the Cnfig Server Security and...